Basic ISDN Legacy DDR Configuration

Router a

 

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Mitreya4000MPlus

!

enable secret 5 $1$51sJ$.h3NUdXcZI/hNuQefakc60

!

username r4500t password 0 wiener

ip subnet-zero

no ip finger

!

isdn switch-type basic-ni

!

interface Loopback0

 ip address 172.255.255.245 255.255.255.255

!

interface Loopback1

 ip address 172.19.21.1 255.255.255.252

!

interface Serial0

 bandwidth 250

 ip address 172.18.45.3 255.255.255.0

 encapsulation frame-relay IETF

 ip ospf network point-to-multipoint

 shutdown

!

interface Serial1

 mtu 4096

 bandwidth 500

 ip address 172.19.19.1 255.255.255.252

 encapsulation frame-relay

 frame-relay interface-dlci 110

!

interface TokenRing0

 ip address 172.19.22.1 255.255.255.0

 shutdown

 ring-speed 16

 multiring all

 source-bridge 10 1 100

 source-bridge spanning

!

!

interface BRI0

 ip address 172.16.3.1 255.255.255.0

 encapsulation ppp

 dialer idle-timeout 60

 dialer map ip 172.16.3.2 name r4500t 8358661

 dialer-group 1

 isdn switch-type basic-ni

 isdn spid1 0835866201 8358662

 isdn spid2 0835866401 8358664

!

interface BRI1

 no ip address

 shutdown

 isdn switch-type basic-ni

!

interface BRI2

 no ip address

 shutdown

 isdn switch-type basic-ni

!

interface BRI3

 no ip address

 shutdown

 isdn switch-type basic-ni

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.3.2

no ip http server

!

dialer-list 1 protocol ip permit

!

!

line con 0

 session-timeout 2880

 exec-timeout 2880 0

 logging synchronous

 transport input none

line aux 0

line vty 0 4

 session-timeout 2880

 exec-timeout 2880 0

 password wiener

 login

!

end

 

 

Router b

 

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname r4500t

!

enable secret 5 $1$dmkQ$LhX8ezIO8y81ypOR34wvt.

!

username r4000m password 0 wiener

ip subnet-zero

isdn switch-type basic-ni

!

!

!

interface Loopback0

 ip address 172.255.255.240 255.255.255.255

 !

interface Ethernet0

 no ip address

 no ip directed-broadcast

 shutdown

 media-type 10BaseT

!

interface Ethernet1

 ip address 172.18.15.254 255.255.255.0

 no ip directed-broadcast

 shutdown

 media-type 10BaseT

!

interface Serial0

 ip address 172.18.45.10 255.255.255.0

 no ip directed-broadcast

 encapsulation frame-relay IETF

 ip ospf network point-to-multipoint

 ip ospf interface-retry 0

 shutdown

!

interface Serial1

 bandwidth 64

 ip address 172.18.113.1 255.255.255.0

 no ip directed-broadcast

 ip ospf interface-retry 0

 shutdown

!

interface BRI0

 ip address 172.16.3.2 255.255.255.0

encapsulation ppp

 dialer idle-timeout 60

 dialer map ip 172.16.3.1 name r4000m 8358662

 dialer-group 1

 isdn switch-type basic-ni

 isdn spid1 0835866101 8358661

 isdn spid2 0835866301 8358663

!

interface BRI1

 no ip address

shutdown

 isdn switch-type basic-ni

!

interface BRI2

 no ip address

shutdown

 isdn switch-type basic-ni

!

interface BRI3

 no ip address

shutdown

 isdn switch-type basic-ni

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.3.1

!

dialer-list 1 protocol ip permit

!

line con 0

 session-timeout 2880

 exec-timeout 2880 0

 logging synchronous

 transport input none

line aux 0

line vty 0 4

 session-timeout 2880

 exec-timeout 2880 0

 password wiener

 login

!

end