Basic IS-IS Configuration

Basic ISIS Configuration, Level-1, Only (Schematic)

r4000m#sh run

!

version 12.1

!

hostname r4000m

!

ip subnet-zero

!

!

interface Loopback100

 ip address 192.168.3.5 255.255.255.252

 ip router isis

!

interface Loopback101

 ip address 192.168.3.9 255.255.255.248

 ip router isis

!

interface Loopback102

 ip address 192.168.3.17 255.255.255.240

 ip router isis

!

interface Loopback500

 ip address 172.31.254.2 255.255.255.128

 ip router isis

!

interface Serial1

 ip address 192.168.3.2 255.255.255.252

 ip router isis

!

router isis

 net 47.0004.1723.1254.0002.00

 is-type level-1

!

access-list 2 permit 0.0.0.0

access-list 2 deny   any

!

!

line con 0

ne aux 0

line vty 0 4

!

end

 

r4000m#  

 

C       192.168.9.0/24 is directly connected, Loopback0
C       192.168.10.0/24 is directly connected, Loopback1
  172.19.0.0/24 is subnetted, 2 subnets
i L1    172.19.2.0 [115/40] via 192.168.3.1, Serial1
i L1    172.19.1.0 [115/40] via 192.168.3.1, Serial1
  172.18.0.0/29 is subnetted, 4 subnets
i L1    172.18.12.144 [115/40] via 192.168.3.1, Serial1
i L1    172.18.12.128 [115/40] via 192.168.3.1, Serial1
i L1    172.18.12.136 [115/40] via 192.168.3.1, Serial1
i L1    172.18.12.0 [115/40] via 192.168.3.1, Serial1
  172.31.0.0/25 is subnetted, 1 subnets
C       172.31.254.0 is directly connected, Loopback500
  192.168.4.0/24 is variably subnetted, 3 subnets, 2 masks
i L1    192.168.4.0/28 [115/20] via 192.168.3.1, Serial1
i L1    192.168.4.24/29 [115/20] via 192.168.3.1, Serial1
i L1    192.168.4.16/29 [115/20] via 192.168.3.1, Serial1
  192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks
i L1    192.168.5.0/30 [115/30] via 192.168.3.1, Serial1
i L1    192.168.5.200/29 [115/30] via 192.168.3.1, Serial1
i L1    192.168.5.192/29 [115/30] via 192.168.3.1, Serial1
i L1    192.168.5.128/30 [115/30] via 192.168.3.1, Serial1
  192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks
C       192.168.3.8/29 is directly connected, Loopback101
C       192.168.3.0/30 is directly connected, Serial1
C       192.168.3.4/30 is directly connected, Loopback100
C       192.168.3.16/28 is directly connected, Loopback102

   

r4500t#sh run

!

version 12.2

hostname r4500t

!

interface Loopback100

 ip address 192.168.4.17 255.255.255.248

 ip router isis

!

interface Loopback101

 ip address 192.168.4.25 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.4 255.255.255.128

 ip router isis

!

interface Ethernet0

 ip address 192.168.4.2 255.255.255.240

 ip router isis

 media-type 10BaseT

!

interface Serial2

 ip address 192.168.3.1 255.255.255.252

 ip router isis

 clockrate 250000

!

router isis

 net 47.0004.1723.1254.0004.00

 is-type level-1

!

ip classless

no ip http server

!

line con 0

line aux 0

line vty 0 4

line vty 5

!

end

 

r4500t#  

 

  172.19.0.0/24 is subnetted, 2 subnets
i L1    172.19.2.0 [115/30] via 192.168.4.1, Ethernet0
i L1    172.19.1.0 [115/30] via 192.168.4.1, Ethernet0
  172.18.0.0/16 is variably subnetted, 6 subnets, 2 masks
i L1    172.18.12.144/29 [115/30] via 192.168.4.1, Ethernet0
i L1    172.18.12.128/29 [115/30] via 192.168.4.1, Ethernet0
i L1    172.18.12.136/29 [115/30] via 192.168.4.1, Ethernet0
i L1    172.18.12.0/29 [115/30] via 192.168.4.1, Ethernet0
C       172.18.3.0/30 is directly connected, Serial4
  172.31.0.0/25 is subnetted, 1 subnets
C       172.31.254.0 is directly connected, Loopback500
  192.168.4.0/24 is variably subnetted, 3 subnets, 2 masks
C       192.168.4.0/28 is directly connected, Ethernet0
C       192.168.4.24/29 is directly connected, Loopback101
C       192.168.4.16/29 is directly connected, Loopback100
  192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks
i L1    192.168.5.0/30 [115/20] via 192.168.4.1, Ethernet0
i L1    192.168.5.200/29 [115/20] via 192.168.4.1, Ethernet0
i L1    192.168.5.192/29 [115/20] via 192.168.4.1, Ethernet0
i L1    192.168.5.128/30 [115/20] via 192.168.4.1, Ethernet0
  192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks
i L1    192.168.3.8/29 [115/20] via 192.168.3.2, Serial2
C 192.168.3.0/30 is directly connected, Serial2
i L1    192.168.3.4/30 [115/20] via 192.168.3.2, Serial2
i L1    192.168.3.16/28 [115/20] via 192.168.3.2, Serial2

r7010#sh run

!

version 12.2

!

hostname r7010

!

interface Loopback10

 ip address 192.168.5.193 255.255.255.248

 ip router isis

!

interface Loopback11

 ip address 192.168.5.201 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.1 255.255.255.128

 ip router isis

!

interface Serial0/0

 no ip address

 encapsulation frame-relay IETF

!

interface Serial0/0.16 point-to-point

 ip address 192.168.5.1 255.255.255.252

 ip router isis

  frame-relay interface-dlci 16

!

interface Serial0/0.17 point-to-point

 ip address 192.168.5.129 255.255.255.252

 ip router isis

 frame-relay interface-dlci 17

!

interface Ethernet1/0

 ip address 192.168.4.1 255.255.255.240

 ip router isis

  isis priority 127

!

router isis

 net 47.0001.1723.1254.0001.00

 net 47.0002.1723.1254.0001.00

 net 47.0004.1723.1254.0001.00

 is-type level-1

!

line con 0

line aux 0

line vty 0 4

end

 

r7010#  

 

r7010 show ip route

 

  172.19.0.0/24 is subnetted, 2 subnets
i L1    172.19.2.0 [115/20] via 192.168.5.2, Serial0/0.16
i L1    172.19.1.0 [115/20] via 192.168.5.2, Serial0/0.16
  172.18.0.0/29 is subnetted, 4 subnets
i L1    172.18.12.144 [115/20] via 192.168.5.130, Serial0/0.17
i L1    172.18.12.128 [115/20] via 192.168.5.130, Serial0/0.17
i L1    172.18.12.136 [115/20] via 192.168.5.130, Serial0/0.17
i L1    172.18.12.0 [115/20] via 192.168.5.130, Serial0/0.17
  172.31.0.0/25 is subnetted, 1 subnets
C       172.31.254.0 is directly connected, Loopback500
  192.168.4.0/24 is variably subnetted, 3 subnets, 2 masks
C       192.168.4.0/28 is directly connected, Ethernet1/0
i L1    192.168.4.24/29 [115/20] via 192.168.4.2, Ethernet1/0
i L1    192.168.4.16/29 [115/20] via 192.168.4.2, Ethernet1/0
  192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks
C       192.168.5.0/30 is directly connected, Serial0/0.16
C       192.168.5.200/29 is directly connected, Loopback11
C       192.168.5.192/29 is directly connected, Loopback10
C       192.168.5.128/30 is directly connected, Serial0/0.17
  192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks
i L1    192.168.3.8/29 [115/30] via 192.168.4.2, Ethernet1/0
i L1    192.168.3.0/30 [115/20] via 192.168.4.2, Ethernet1/0
i L1    192.168.3.4/30 [115/30] via 192.168.4.2, Ethernet1/0
i L1    192.168.3.16/28 [115/30] via 192.168.4.2, Ethernet1/0

r3660#sh run

!

version 12.2

!

hostname r3660

!

interface Loopback10

 ip address 172.19.1.1 255.255.255.0

 ip router isis

!

interface Loopback11

 ip address 172.19.2.1 255.255.255.0

 ip router isis

!

interface Loopback500

 ip address 172.31.254.3 255.255.255.128

 ip router isis

!

interface Serial4/0

 no ip address

 encapsulation frame-relay IETF

!

interface Serial4/0.610 point-to-point

 ip address 192.168.5.2 255.255.255.252

 ip router isis

 frame-relay interface-dlci 61

!

router isis

 net 47.0001.1723.1254.0003.00

 is-type level-1

!

ip classless

!

line con 0

line aux 0

line vty 0 4

!

end

 

r3660#  

 

  172.19.0.0/24 is subnetted, 2 subnets
C       172.19.2.0 is directly connected, Loopback11
C       172.19.1.0 is directly connected, Loopback10
  172.18.0.0/29 is subnetted, 4 subnets
i L1   172.18.12.144 [115/30] via 192.168.5.1, Serial4/0.610
i L1   172.18.12.128 [115/30] via 192.168.5.1, Serial4/0.610
i L1   172.18.12.136 [115/30] via 192.168.5.1, Serial4/0.610
i L1   172.18.12.0 [115/30] via 192.168.5.1, Serial4/0.610
  172.31.0.0/25 is subnetted, 1 subnets
C       172.31.254.0 is directly connected, Loopback500
  192.168.4.0/24 is variably subnetted, 3 subnets, 2 masks
i L1   192.168.4.0/28 [115/20] via 192.168.5.1, Serial4/0.610
i L1   192.168.4.24/29 [115/30] via 192.168.5.1, Serial4/0.610
i L1   192.168.4.16/29 [115/30] via 192.168.5.1, Serial4/0.610
  192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks
C       192.168.5.0/30 is directly connected, Serial4/0.610
i L1   192.168.5.200/29 [115/20] via 192.168.5.1, Serial4/0.610
i L1   192.168.5.192/29 [115/20] via 192.168.5.1, Serial4/0.610
i L1   192.168.5.128/30 [115/20] via 192.168.5.1, Serial4/0.610
192.  168.255.0/32 is subnetted, 1 subnets
C      192.168.255.254 is directly connected, Loopback0
 192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks
i L1   192.168.3.8/29 [115/40] via 192.168.5.1, Serial4/0.610
i L1   192.168.3.0/30 [115/30] via 192.168.5.1, Serial4/0.610
i L1   192.168.3.4/30 [115/40] via 192.168.5.1, Serial4/0.610
i L1   192.168.3.16/28 [115/40] via 192.168.5.1, Serial4/0.610

 

r4500b#sh run

!

version 12.2

!

hostname r4500b

!

interface Loopback10

 ip address 172.18.12.1 255.255.255.248

 ip router isis

!

interface Loopback11

 ip address 172.18.12.129 255.255.255.248

 ip router isis

!

interface Loopback12

 ip address 172.18.12.137 255.255.255.248

 ip router isis

!

interface Loopback13

 ip address 172.18.12.145 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.5 255.255.255.128

 ip router isis

!

interface Serial1

 no ip address

 encapsulation frame-relay IETF

!

interface Serial1.710 point-to-point

 ip address 192.168.5.130 255.255.255.252

 ip router isis

 frame-relay interface-dlci 71

!

router isis

 net 47.0002.1723.1254.0005.00

 is-type level-1

!

!

ip classless

!

line con 0

line aux 0

line vty 0 4

 !

end

 

r4500b#  

 

  172.19.0.0/24 is subnetted, 2 subnets
i L1    172.19.2.0 [115/30] via 192.168.5.129, Serial1.710
i L1    172.19.1.0 [115/30] via 192.168.5.129, Serial1.710
  172.18.0.0/16 is variably subnetted, 5 subnets, 2 masks
C       172.18.12.144/29 is directly connected, Loopback13
S       172.18.12.128/25 is directly connected, Null0
C       172.18.12.128/29 is directly connected, Loopback11
C       172.18.12.136/29 is directly connected, Loopback12
C       172.18.12.0/29 is directly connected, Loopback10
  172.31.0.0/25 is subnetted, 1 subnets
C       172.31.254.0 is directly connected, Loopback500
  192.168.4.0/24 is variably subnetted, 3 subnets, 2 masks
i L1    192.168.4.0/28 [115/20] via 192.168.5.129, Serial1.710
i L1    192.168.4.24/29 [115/30] via 192.168.5.129, Serial1.710
i L1    192.168.4.16/29 [115/30] via 192.168.5.129, Serial1.710
  192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks
i L1    192.168.5.0/30 [115/20] via 192.168.5.129, Serial1.710
i L1    192.168.5.200/29 [115/20] via 192.168.5.129, Serial1.710
i L1    192.168.5.192/29 [115/20] via 192.168.5.129, Serial1.710
C       192.168.5.128/30 is directly connected, Serial1.710
C       192.168.172.0/24 is directly connected, Loopback0
  192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks
i L1    192.168.3.8/29 [115/40] via 192.168.5.129, Serial1.710
i L1    192.168.3.0/30 [115/30] via 192.168.5.129, Serial1.710
i L1    192.168.3.4/30 [115/40] via 192.168.5.129, Serial1.710
i L1    192.168.3.16/28 [115/40] via 192.168.5.129, Serial1.710