Multi-Area IS-IS w/ VoIP

Configuration

A simple multi-area IS-IS configuration with two OSPF domains to support VoIP access to the network.  The VoIP transits the IS-IS backbone.  The phones are configured for Private Line Automatic Ringdown (PLAR), which provides a convenient IS-IS configuration ping.  If IS-IS is working correctly, lifting either handset results in a ring at the other side.

mc3810b#sh run

!

version 12.1

!

hostname mc3810b

ip subnet-zero

!

interface Loopback20

 ip address 192.168.2.5 255.255.255.252

!

interface Serial0

 ip address 192.168.2.2 255.255.255.252

!

router ospf 10

 network 192.168.2.0 0.0.0.3 area 0

 network 192.168.2.4 0.0.0.3 area 0

!

no ip http server

ip classless

!

!

voice-port 1/1

 connection plar 1000

!

dial-peer voice 3000 pots

 destination-pattern 3000

 port 1/1

!

dial-peer voice 1000 voip

 destination-pattern 1000

 session target ipv4:172.18.12.34

!

num-exp 1 1000

!

line con 0

line aux 0

line 2 3

line vty 0 4

 login

!

end

 

mc3810b#

mc3810b#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 192.168.2.1 to network 0.0.0.0

 

     192.168.8.0/32 is subnetted, 1 subnets

O       192.168.8.1 [110/65] via 192.168.2.1, 3d05h, Serial0

     192.168.9.0/32 is subnetted, 1 subnets

O       192.168.9.1 [110/65] via 192.168.2.1, 3d05h, Serial0

     192.168.10.0/32 is subnetted, 1 subnets

O       192.168.10.1 [110/65] via 192.168.2.1, 3d05h, Serial0

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.2.0/30 is subnetted, 2 subnets

C       192.168.2.0 is directly connected, Serial0

C       192.168.2.4 is directly connected, Loopback20

     150.100.0.0/24 is subnetted, 4 subnets

O E2    150.100.2.0 [110/20] via 192.168.2.1, 01:23:58, Serial0

O E2    150.100.3.0 [110/20] via 192.168.2.1, 01:23:44, Serial0

O E2    150.100.0.0 [110/20] via 192.168.2.1, 01:24:34, Serial0

O E2    150.100.1.0 [110/20] via 192.168.2.1, 01:24:18, Serial0

     192.168.3.0/24 is variably subnetted, 3 subnets, 3 masks

C       192.168.3.8/29 is directly connected, Loopback101

C       192.168.3.4/30 is directly connected, Loopback100

C       192.168.3.16/28 is directly connected, Loopback102

O*E2 0.0.0.0/0 [110/1] via 192.168.2.1, 00:00:09, Serial0

mc3810b#

 

r4000m#sh run

!

version 12.1

!

hostname r4000m

!

ip subnet-zero

!

interface Loopback0

 ip address 192.168.9.1 255.255.255.0

!

interface Loopback1

 ip address 192.168.10.1 255.255.255.0

!

interface Loopback2

 ip address 192.168.8.1 255.255.255.252

!

interface Loopback100

 ip address 192.168.3.5 255.255.255.252

 ip router isis

!

interface Loopback101

 ip address 192.168.3.9 255.255.255.248

 ip router isis

!

interface Loopback102

 ip address 192.168.3.17 255.255.255.240

 ip router isis

!

interface Loopback500

 ip address 172.31.254.2 255.255.255.128

 ip router isis

!

interface Serial0

 ip address 192.168.2.1 255.255.255.252

 clockrate 250000

!

interface Serial1

 ip address 192.168.3.2 255.255.255.252

 ip router isis

 isis circuit-type level-1

!

router ospf 10

 log-adjacency-changes

 redistribute static subnets

 network 192.168.2.0 0.0.0.3 area 0

 network 192.168.8.0 0.0.0.3 area 0

 network 192.168.9.0 0.0.0.255 area 0

 network 192.168.10.0 0.0.0.255 area 0

 default-information originate

!

router isis

 summary-address 192.168.2.0 255.255.255.248 level-1

 redistribute static ip level-1

 redistribute ospf 10 level-1

 net 47.0004.1720.3125.4002.00

 is-type level-1

 metric-style wide

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.3.1

ip route 150.100.0.0 255.255.255.0 Null0

ip route 150.100.1.0 255.255.255.0 Null0

ip route 150.100.2.0 255.255.255.0 Null0

ip route 150.100.3.0 255.255.255.0 Null0

no ip http server

!

line con 0

line aux 0

line vty 0 4

 

!

end

 

r4000m#

r4000m#Sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 192.168.3.1 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

C       192.168.8.0 is directly connected, Loopback2

C    192.168.9.0/24 is directly connected, Loopback0

C    192.168.10.0/24 is directly connected, Loopback1

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 5 subnets, 2 masks

i L1    192.168.4.24/29 [115/20] via 192.168.3.1, Serial1

i L1    192.168.4.16/29 [115/20] via 192.168.3.1, Serial1

i L1    192.168.4.192/28 [115/20] via 192.168.3.1, Serial1

i L1    192.168.4.216/29 [115/30] via 192.168.3.1, Serial1

i L1    192.168.4.208/29 [115/30] via 192.168.3.1, Serial1

     192.168.2.0/24 is variably subnetted, 3 subnets, 3 masks

i su    192.168.2.0/29 [115/0] via 0.0.0.0, Null0

C       192.168.2.0/30 is directly connected, Serial0

O       192.168.2.5/32 [110/65] via 192.168.2.2, 3d04h, Serial0

     150.100.0.0/24 is subnetted, 4 subnets

S       150.100.2.0 is directly connected, Null0

S       150.100.3.0 is directly connected, Null0

S       150.100.0.0 is directly connected, Null0

S       150.100.1.0 is directly connected, Null0

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

C       192.168.3.8/29 is directly connected, Loopback101

C       192.168.3.0/30 is directly connected, Serial1

C       192.168.3.4/30 is directly connected, Loopback100

C       192.168.3.16/28 is directly connected, Loopback102

S*   0.0.0.0/0 [1/0] via 192.168.3.1

r4000m#

 

r2501b#sh run

!

version 12.2

!

hostname r2501b

!

interface Loopback10

 ip address 192.168.4.209 255.255.255.248

 ip router isis

!

interface Loopback11

 ip address 192.168.4.217 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.8 255.255.255.128

 ip router isis

!

interface Ethernet0

 ip address 192.168.4.193 255.255.255.240

 ip router isis

!

router isis

 net 47.0004.1720.3125.4008.00

 is-type level-1

 metric-style wide

!

line con 0

line aux 0

line vty 0 4

!

end

 

r2501b#

r2501b#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 192.168.4.194 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

i L1    192.168.8.0 [115/20] via 192.168.4.194, Ethernet0

i L1 192.168.9.0/24 [115/20] via 192.168.4.194, Ethernet0

i L1 192.168.10.0/24 [115/20] via 192.168.4.194, Ethernet0

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 5 subnets, 2 masks

i L1    192.168.4.24/29 [115/20] via 192.168.4.194, Ethernet0

i L1    192.168.4.16/29 [115/20] via 192.168.4.194, Ethernet0

C       192.168.4.192/28 is directly connected, Ethernet0

C       192.168.4.216/29 is directly connected, Loopback11

C       192.168.4.208/29 is directly connected, Loopback10

     192.168.2.0/29 is subnetted, 1 subnets

i L1    192.168.2.0 [115/20] via 192.168.4.194, Ethernet0

     150.100.0.0/24 is subnetted, 4 subnets

i L1    150.100.2.0 [115/20] via 192.168.4.194, Ethernet0

i L1    150.100.3.0 [115/20] via 192.168.4.194, Ethernet0

i L1    150.100.0.0 [115/20] via 192.168.4.194, Ethernet0

i L1    150.100.1.0 [115/20] via 192.168.4.194, Ethernet0

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

i L1    192.168.3.8/29 [115/30] via 192.168.4.194, Ethernet0

i L1    192.168.3.0/30 [115/20] via 192.168.4.194, Ethernet0

i L1    192.168.3.4/30 [115/30] via 192.168.4.194, Ethernet0

i L1    192.168.3.16/28 [115/30] via 192.168.4.194, Ethernet0

i*L1 0.0.0.0/0 [115/10] via 192.168.4.194, Ethernet0

r2501b#

 

r4500t#sh run

!

version 12.2

!

hostname r4500t

!

interface Loopback100

 ip address 192.168.4.17 255.255.255.248

 ip router isis

!

interface Loopback101

 ip address 192.168.4.25 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.4 255.255.255.128

 ip router isis

!

interface Ethernet0

 ip address 192.168.4.2 255.255.255.248

 ip router isis

 media-type 10BaseT

 isis circuit-type level-2-only

!

interface Ethernet1

 ip address 192.168.4.194 255.255.255.240

 ip router isis

 media-type 10BaseT

 isis circuit-type level-1

!

interface Serial2

 ip address 192.168.3.1 255.255.255.252

 ip router isis

 clockrate 250000

 isis circuit-type level-1

!

router isis

 summary-address 150.100.0.0 255.255.252.0

 net 47.0004.1720.3125.4004.00

 metric-style wide

!

!

line con 0

line aux 0

line vty 0 4

line vty 5

!

end

 

r4500t#

r4500t#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 192.168.4.1 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

i L1    192.168.8.0 [115/10] via 192.168.3.2, Serial2

i L1 192.168.9.0/24 [115/10] via 192.168.3.2, Serial2

i L1 192.168.10.0/24 [115/10] via 192.168.3.2, Serial2

     172.19.0.0/24 is subnetted, 2 subnets

i L2    172.19.2.0 [115/30] via 192.168.4.1, Ethernet0

i L2    172.19.1.0 [115/30] via 192.168.4.1, Ethernet0

     172.18.0.0/16 is variably subnetted, 5 subnets, 2 masks

i L2    172.18.12.144/29 [115/30] via 192.168.4.1, Ethernet0

i L2    172.18.12.128/29 [115/30] via 192.168.4.1, Ethernet0

i L2    172.18.12.136/29 [115/30] via 192.168.4.1, Ethernet0

i L2    172.18.12.32/28 [115/20] via 192.168.4.1, Ethernet0

i L2    172.18.12.0/29 [115/30] via 192.168.4.1, Ethernet0

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 7 subnets, 2 masks

i L2    192.168.4.0/28 [115/20] via 192.168.4.1, Ethernet0

C       192.168.4.0/29 is directly connected, Ethernet0

C       192.168.4.24/29 is directly connected, Loopback101

C       192.168.4.16/29 is directly connected, Loopback100

C       192.168.4.192/28 is directly connected, Ethernet1

i L1    192.168.4.216/29 [115/20] via 192.168.4.193, Ethernet1

i L1    192.168.4.208/29 [115/20] via 192.168.4.193, Ethernet1

     192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks

i L2    192.168.5.0/30 [115/20] via 192.168.4.1, Ethernet0

i L2    192.168.5.200/29 [115/20] via 192.168.4.1, Ethernet0

i L2    192.168.5.192/29 [115/20] via 192.168.4.1, Ethernet0

i L2    192.168.5.128/30 [115/20] via 192.168.4.1, Ethernet0

     192.168.2.0/29 is subnetted, 1 subnets

i L1    192.168.2.0 [115/10] via 192.168.3.2, Serial2

     150.100.0.0/16 is variably subnetted, 5 subnets, 2 masks

i L1    150.100.2.0/24 [115/10] via 192.168.3.2, Serial2

i L1    150.100.3.0/24 [115/10] via 192.168.3.2, Serial2

i su    150.100.0.0/22 [115/10] via 0.0.0.0, Null0

i L1    150.100.0.0/24 [115/10] via 192.168.3.2, Serial2

i L1    150.100.1.0/24 [115/10] via 192.168.3.2, Serial2

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

i L1    192.168.3.8/29 [115/20] via 192.168.3.2, Serial2

C       192.168.3.0/30 is directly connected, Serial2

i L1    192.168.3.4/30 [115/20] via 192.168.3.2, Serial2

i L1    192.168.3.16/28 [115/20] via 192.168.3.2, Serial2

i*L2 0.0.0.0/0 [115/20] via 192.168.4.1, Ethernet0

r4500t#

 

r7010#sh run

!

version 12.2

!

hostname r7010

!

!

interface Loopback10

 ip address 192.168.5.193 255.255.255.248

 ip router isis

!

interface Loopback11

 ip address 192.168.5.201 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.1 255.255.255.128

 ip router isis

!

interface Serial0/0

 no ip address

 encapsulation frame-relay IETF

 no ip route-cache

 no ip mroute-cache

 serial restart-delay 0

!

interface Serial0/0.16 point-to-point

 ip address 192.168.5.1 255.255.255.252

 ip router isis

 no ip route-cache

 no ip mroute-cache

 isis circuit-type level-2-only

 frame-relay interface-dlci 16

!

interface Serial0/0.17 point-to-point

 ip address 192.168.5.129 255.255.255.252

 ip router isis

 no ip route-cache

 no ip mroute-cache

 isis circuit-type level-1

 frame-relay interface-dlci 17

!

interface Ethernet1/0

 ip address 192.168.4.1 255.255.255.240

 ip router isis

 no ip route-cache cef

 no ip mroute-cache

 isis circuit-type level-2-only

 isis priority 127

!

router isis

 redistribute isis ip level-2 into level-1 distribute-list 110

 net 47.0002.1723.1254.0001.00

 metric-style wide

!

ip classless

access-list 110 permit ip 192.168.0.0 0.0.127.255 any

access-list 110 permit ip 150.100.0.0 0.0.3.255 any

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

 

r7010#

r7010#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 192.168.5.2 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

i L2    192.168.8.0 [115/20] via 192.168.4.2, Ethernet1/0

i L2 192.168.9.0/24 [115/20] via 192.168.4.2, Ethernet1/0

i L2 192.168.10.0/24 [115/20] via 192.168.4.2, Ethernet1/0

     172.19.0.0/24 is subnetted, 2 subnets

i L2    172.19.2.0 [115/20] via 192.168.5.2, Serial0/0.16

i L2    172.19.1.0 [115/20] via 192.168.5.2, Serial0/0.16

     172.18.0.0/16 is variably subnetted, 5 subnets, 2 masks

i L1    172.18.12.144/29 [115/20] via 192.168.5.130, Serial0/0.17

i L1    172.18.12.128/29 [115/20] via 192.168.5.130, Serial0/0.17

i L1    172.18.12.136/29 [115/20] via 192.168.5.130, Serial0/0.17

i L1    172.18.12.32/28 [115/10] via 192.168.5.130, Serial0/0.17

i L1    172.18.12.0/29 [115/20] via 192.168.5.130, Serial0/0.17

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 7 subnets, 2 masks

i L2    192.168.4.0/29 [115/20] via 192.168.4.2, Ethernet1/0

C       192.168.4.0/28 is directly connected, Ethernet1/0

i L2    192.168.4.24/29 [115/20] via 192.168.4.2, Ethernet1/0

i L2    192.168.4.16/29 [115/20] via 192.168.4.2, Ethernet1/0

i L2    192.168.4.192/28 [115/20] via 192.168.4.2, Ethernet1/0

i L2    192.168.4.216/29 [115/30] via 192.168.4.2, Ethernet1/0

i L2    192.168.4.208/29 [115/30] via 192.168.4.2, Ethernet1/0

     192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks

C       192.168.5.0/30 is directly connected, Serial0/0.16

C       192.168.5.200/29 is directly connected, Loopback11

C       192.168.5.192/29 is directly connected, Loopback10

C       192.168.5.128/30 is directly connected, Serial0/0.17

     192.168.2.0/29 is subnetted, 1 subnets

i L2    192.168.2.0 [115/20] via 192.168.4.2, Ethernet1/0

     150.100.0.0/22 is subnetted, 1 subnets

i L2    150.100.0.0 [115/20] via 192.168.4.2, Ethernet1/0

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

i L2    192.168.3.8/29 [115/30] via 192.168.4.2, Ethernet1/0

i L2    192.168.3.0/30 [115/20] via 192.168.4.2, Ethernet1/0

i L2    192.168.3.4/30 [115/30] via 192.168.4.2, Ethernet1/0

i L2    192.168.3.16/28 [115/30] via 192.168.4.2, Ethernet1/0

i*L2 0.0.0.0/0 [115/10] via 192.168.5.2, Serial0/0.16

r7010#

 

r3660#sh run

!

version 12.2

!

hostname r3660

!

interface Loopback10

 ip address 172.19.1.1 255.255.255.0

 ip router isis

!

interface Loopback11

 ip address 172.19.2.1 255.255.255.0

 ip router isis

!

interface Loopback500

 ip address 172.31.254.3 255.255.255.128

 ip router isis

!

interface Serial4/0

 no ip address

 encapsulation frame-relay IETF

!

interface Serial4/0.610 point-to-point

 ip address 192.168.5.2 255.255.255.252

 ip router isis

 isis circuit-type level-2-only

 frame-relay interface-dlci 61

!

router isis

 default-information originate

 net 47.0001.1723.1254.0003.00

 is-type level-2-only

 metric-style wide

!

ip route 0.0.0.0 0.0.0.0 Null0

!

line con 0

line 33 48

line aux 0

line vty 0 4

!

end

 

r3660#

r3660#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

i L2    192.168.8.0 [115/30] via 192.168.5.1, Serial4/0.610

i L2 192.168.9.0/24 [115/30] via 192.168.5.1, Serial4/0.610

i L2 192.168.10.0/24 [115/30] via 192.168.5.1, Serial4/0.610

     172.19.0.0/24 is subnetted, 2 subnets

C       172.19.2.0 is directly connected, Loopback11

C       172.19.1.0 is directly connected, Loopback10

     172.18.0.0/16 is variably subnetted, 5 subnets, 2 masks

i L2    172.18.12.144/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    172.18.12.128/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    172.18.12.136/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    172.18.12.32/28 [115/20] via 192.168.5.1, Serial4/0.610

i L2    172.18.12.0/29 [115/30] via 192.168.5.1, Serial4/0.610

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 7 subnets, 2 masks

i L2    192.168.4.0/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.0/28 [115/20] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.24/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.16/29 [115/30] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.192/28 [115/30] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.216/29 [115/40] via 192.168.5.1, Serial4/0.610

i L2    192.168.4.208/29 [115/40] via 192.168.5.1, Serial4/0.610

     192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks

C       192.168.5.0/30 is directly connected, Serial4/0.610

i L2    192.168.5.200/29 [115/20] via 192.168.5.1, Serial4/0.610

i L2    192.168.5.192/29 [115/20] via 192.168.5.1, Serial4/0.610

i L2    192.168.5.128/30 [115/20] via 192.168.5.1, Serial4/0.610

     192.168.255.0/32 is subnetted, 1 subnets

C       192.168.255.254 is directly connected, Loopback0

     192.168.2.0/29 is subnetted, 1 subnets

i L2    192.168.2.0 [115/30] via 192.168.5.1, Serial4/0.610

     150.100.0.0/22 is subnetted, 1 subnets

i L2    150.100.0.0 [115/30] via 192.168.5.1, Serial4/0.610

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

i L2    192.168.3.8/29 [115/40] via 192.168.5.1, Serial4/0.610

i L2    192.168.3.0/30 [115/30] via 192.168.5.1, Serial4/0.610

i L2    192.168.3.4/30 [115/40] via 192.168.5.1, Serial4/0.610

i L2    192.168.3.16/28 [115/40] via 192.168.5.1, Serial4/0.610

S*   0.0.0.0/0 is directly connected, Null0

r3660#

 

r4500b#sh run

!

version 12.2

!

hostname r4500b

!

interface Loopback10

 ip address 172.18.12.1 255.255.255.248

 ip router isis

!

interface Loopback11

 ip address 172.18.12.129 255.255.255.248

 ip router isis

!

interface Loopback12

 ip address 172.18.12.137 255.255.255.248

 ip router isis

!

interface Loopback13

 ip address 172.18.12.145 255.255.255.248

 ip router isis

!

interface Loopback500

 ip address 172.31.254.5 255.255.255.128

 ip router isis

!

interface Ethernet0

 ip address 172.18.12.33 255.255.255.248

 media-type 10BaseT

!

interface Serial1

 no ip address

 encapsulation frame-relay IETF

!

interface Serial1.710 point-to-point

 ip address 192.168.5.130 255.255.255.252

 ip router isis

 isis circuit-type level-1

 frame-relay interface-dlci 71

!

router ospf 11

 log-adjacency-changes

 network 172.18.12.32 0.0.0.7 area 0

 network 192.168.12.32 0.0.0.7 area 0

 default-information originate

!

router isis

 summary-address 172.18.12.32 255.255.255.240 level-1

 no redistribute static clns

 redistribute ospf 11 level-1

 net 47.0002.1723.1254.0005.00

 is-type level-1

 metric-style wide

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.5.2

no ip http server

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

 

r4500b#

r4500b#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 192.168.5.2 to network 0.0.0.0

 

     192.168.8.0/30 is subnetted, 1 subnets

i ia    192.168.8.0 [115/30] via 192.168.5.129, Serial1.710

i ia 192.168.9.0/24 [115/30] via 192.168.5.129, Serial1.710

i ia 192.168.10.0/24 [115/30] via 192.168.5.129, Serial1.710

     172.18.0.0/16 is variably subnetted, 7 subnets, 3 masks

C       172.18.12.144/29 is directly connected, Loopback13

C       172.18.12.128/29 is directly connected, Loopback11

C       172.18.12.136/29 is directly connected, Loopback12

i su    172.18.12.32/28 [115/0] via 0.0.0.0, Null0

C       172.18.12.32/29 is directly connected, Ethernet0

O       172.18.12.41/32 [110/11] via 172.18.12.34, 02:06:36, Ethernet0

C       172.18.12.0/29 is directly connected, Loopback10

     172.31.0.0/25 is subnetted, 1 subnets

C       172.31.254.0 is directly connected, Loopback500

     192.168.4.0/24 is variably subnetted, 7 subnets, 2 masks

i ia    192.168.4.0/28 [115/20] via 192.168.5.129, Serial1.710

i ia    192.168.4.0/29 [115/30] via 192.168.5.129, Serial1.710

i ia    192.168.4.24/29 [115/30] via 192.168.5.129, Serial1.710

i ia    192.168.4.16/29 [115/30] via 192.168.5.129, Serial1.710

i ia    192.168.4.192/28 [115/30] via 192.168.5.129, Serial1.710

i ia    192.168.4.216/29 [115/40] via 192.168.5.129, Serial1.710

i ia    192.168.4.208/29 [115/40] via 192.168.5.129, Serial1.710

     192.168.5.0/24 is variably subnetted, 4 subnets, 2 masks

i ia    192.168.5.0/30 [115/20] via 192.168.5.129, Serial1.710

i L1    192.168.5.200/29 [115/20] via 192.168.5.129, Serial1.710

i L1    192.168.5.192/29 [115/20] via 192.168.5.129, Serial1.710

C       192.168.5.128/30 is directly connected, Serial1.710

C    192.168.172.0/24 is directly connected, Loopback0

     192.168.2.0/29 is subnetted, 1 subnets

i ia    192.168.2.0 [115/30] via 192.168.5.129, Serial1.710

     150.100.0.0/22 is subnetted, 1 subnets

i ia    150.100.0.0 [115/30] via 192.168.5.129, Serial1.710

     192.168.3.0/24 is variably subnetted, 4 subnets, 3 masks

i ia    192.168.3.8/29 [115/40] via 192.168.5.129, Serial1.710

i ia    192.168.3.0/30 [115/30] via 192.168.5.129, Serial1.710

i ia    192.168.3.4/30 [115/40] via 192.168.5.129, Serial1.710

i ia    192.168.3.16/28 [115/40] via 192.168.5.129, Serial1.710

S*   0.0.0.0/0 [1/0] via 192.168.5.2

r4500b#

 

mc3810a#sh run

!

version 12.1

!

hostname mc3810a

!

interface Loopback0

 ip address 172.18.12.41 255.255.255.248

!

interface Ethernet0

 ip address 172.18.12.34 255.255.255.248

!

router ospf 11

 network 172.18.12.32 0.0.0.7 area 0

 network 172.18.12.40 0.0.0.7 area 0

!

voice-port 1/1

 connection plar 3000

!

dial-peer voice 1000 pots

 destination-pattern 1000

 port 1/1

!

dial-peer voice 3000 voip

 destination-pattern 3000

 session target ipv4:192.168.2.2

!

num-exp 3 3000

!

line con 0

line aux 0

line 2 3

line vty 0 4

!

end

 

mc3810a#

mc3810a#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is 172.18.12.33 to network 0.0.0.0

 

     172.18.0.0/29 is subnetted, 2 subnets

C       172.18.12.32 is directly connected, Ethernet0

C       172.18.12.40 is directly connected, Loopback0

O*E2 0.0.0.0/0 [110/1] via 172.18.12.33, 00:52:33, Ethernet0